Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 18:00 BST
Scheduled
Description of works: During the maintenance window our third party datacenter provider will be carrying out maintenance work on to perform core network enhancements and critical upgrades on a London transport node.
How does it affect the services we offer? No downtime is expected but elements of the platform should be considered at-risk.
If you need any support or have any questions please contact our Service Desk: Phone: +44(0)333 2000 991 Email support@eloquent-technologies.com
Posted Sep 25, 2025 - 14:18 BST
This scheduled maintenance affected: Core Network, Hosted Servers, Customer Network, and Application Delivery Platform.