A fix has been implemented and we're monitoring the results.
Posted Oct 04, 2025 - 14:01 BST
Update
We have identified the issue and we are working with our suppliers and Fortinet to get this resolved.
Posted Oct 04, 2025 - 11:55 BST
Investigating
Our team is investigating an issue affecting Citrix, server hosts, and lines. We are working to resolve this as quickly as possible and will continue to provide updates.
Posted Oct 04, 2025 - 10:46 BST
This incident affected: Core Network and Hosted Servers.